Совет 1: Как увеличить аргументы функции "если" в Excel

Назначение логической функции «если» в табличном редакторе Microsoft Office Excel заключается в проверке истинности переданного ей выражения. В зависимости от результата этой проверки функция возвращает одно из двух переданных ей для этого значений. Каждый из трех параметров - условие и два возвращаемых результата - тоже могут быть функциями сравнения, что позволяет сравнивать любое количество аргументов.
Как увеличить аргументы функции "если" в Excel
Вам понадобится
  • Базовые навыки работы с функциями Excel.
Инструкция
1
Используйте логические оператор «и» чтобы увеличить количество сравниваемых с использованием функции «если» аргументов. Он позволит задействовать больше операций сравнения в тех случаях, когда необходимым является истинность всех перечисленных в аргументах операций сравнения. Например, если эта функция должна вернуть единицу при условии, что значение в ячейке A1 больше значения в ячейке A5, а значение B1 совпадает со значением B3, то функцию «если» можно записать так: ЕСЛИ(И(A1>A5;B1=B3);1;2). Количество аргументов функции «и» не может быть больше 30, но каждый из них сам может содержать функцию «и», поэтому у вас есть возможность составить матрешку из функций любого разумного уровня вложенности.
2
Иногда вместо условия необходимого нужно проверить условие достаточное. В таких случаях вместо функции «и» расширяйте количество аргументов с использованием функции «или». Скажем, требуется, чтобы функция «если» возвращала единицу, когда либо значение в ячейке A1 больше значения в ячейке A5, либо значение B1 совпадает со значением B3, либо значение A4 является отрицательным числом. Если не соблюдено ни одно из условий, то функция должна вернуть ноль. Такую конструкцию из трех сравниваемых и двух возвращаемых аргументов функции «если» можно записать так: ЕСЛИ(ИЛИ(A1>A5;B1=B3;A4
3
Комбинируйте функции «и», «или» и «если» на разных уровнях вложенности, чтобы получить оптимальный алгоритм сравнения нужного количества аргументов. Например: ЕСЛИ(ИЛИ(A1>A5;ЕСЛИ(И(A7>A5;B1
4
Используйте второй и третий аргументы функции «если» (возвращаемые значения) для увеличения количества сравниваемых параметров. Каждый из них может содержать по семь уровней вложения с функциями «и», «или» и «если». При этом не забывайте, что закладываемые вами во второй аргумент операции сравнения будут проверяться только в том случае, если операция сравнения в первом аргументе «если» вернет значение «истина». В противном случае проверяться будут функции, записываемые на позицию третьего аргумента.
Видео по теме
Источники:
  • как составить аргументы

Совет 2 : 5 полезных функций в Microsoft Excel

Microsoft Excel - одна из наиболее популярных и успешных офис-программ. Однако, далеко не каждый менеджер использует весь функционал данной программы. Так что если вы хотите преуспеть в своем бизнесе и поразить своих боссов - изучайте новые функции в Экселе.
5 полезных функций в Microsoft Excel
Инструкция
1
Функция ВПР.
Находит нужное значение в таблице.

Пример использования.
Чтобы узнать балл Кати, пишем =ВПР(“Катя”,A1:E1,2,0)
где "Катя" - имя ученицы, A1:E1 - диапазон ячеек поиска, 2 - номер столбца, 0 значит, что нам не требуется найти точного соответствия значению.

Особенности использования.
К сожалению, функция способна искать только слева направо. Кроме всего прочего, по большим таблицам функция может искать довольно продолжительное время.
2
Функция ИНДЕКС.
Находит значение на пересечении нужных строки и столбца.

Пример использования.
Чтобы узнать, кто стал первым в забеге, набираем: =ИНДЕКС(А1:А11, 1)
где А1:А11 - диапазон ячеек поиска, а 1 означает, что нам нужен именно тот, кто пришел первым.
3
Функция ПОИСКПОЗ.
Находит значение в диапазоне ячеек и отражает позицию данного значения.

Пример использования.
Чтобы найти имя руководителя фирмы "Старатели", вводим =ПОИСКПОЗ("Старатели",B3:B13,0)
где "Старатели" - название фирмы, B3:B13 - диапазон ячеек поиска, а 0 означает, что мы не ищем точного значения.
4
Функция $.
Позволяет отменить автоматическую корректировку формулы при копировании таковой в новую ячейку.

Пример использования.
Если написать "$A$1" - значение скопированной ячейки данных станет одинаковым в любом направлении.
5
Функция &.
Помогает собрать все значения ячеек в одну.

Аналоги.
Действует аналогично функции СЦЕПИТЬ.
Видео по теме
Обратите внимание
По отдельности функции ПОИСКПОЗ и ИНДЕКС не представляют собой идеальные поисковые функции, но их сочетание вполне может заменить собой функцию ВПР.
Совет полезен?
Поиск
Добавить комментарий к статье
Осталось символов: 500